Am I Running The Correct Apple FireWire Audio Driver For My Version Of Mac OS X?

If you are experiencing problems using a Saffire/Saffire LE/Saffire PRO 10i/o or Saffire Pro 26i/o on a computer running Mac OS X, it is worth checking that you have the correct version of the Apple FireWire Audio (AFWA) driver installed on your system. This driver is utilised by the Saffire units listed above, the Current Saffire range have their own drivers so this article is not relevant to them.

To check what version of the FireWire Audio Driver you are running, please follow the instructions below:

Go to ABOUT THIS MAC (this can be found under the APPLE menu in the top left-hand corner of your desktop).

Click on MORE INFO and then go to SOFTWARE>EXTENSIONS in your System Profile. The Apple FireWire Audio Driver (AppleFWAudio) should appear in a list with its version number next to it, as shown in this screenshot:



Note that if you are not running any hardware that uses the AppleFWAudio driver, it will not appear here.

Instead, you can check your AppleFWAudio version by finding the extension itself.

Extensions are kept in /System/Library/Extensions/.

Control + click (or right click) on the AppleFWAudio extension and go to 'Get Info' to view information such as its version.

The table below lists which driver you should be running, depending on which version of OS X is installed on your computer:

Operating System AFWA Driver Version
10.4 - 10.4.10 2.1.0
10.4.11 2.2.0
10.5 - 10.5.2 2.4.0
10.5.3 - 10.5.5 2.4.2
10.5.6 2.4.4
10.5.7 2.4.6



Version 2.2.0 is installed with the 10.4.11 update, version 2.4.0 is installed with 10.5 (Leopard), version 2.4.2 is installed with the 10.5.3 update. 2.4.4 is installed with the 10.5.6 update, version 2.4.6 is installed with the 10.5.7 update.

If you continue to experience problems, please contact Customer Support.