Dream Big with Focusrite - Win a dream recording weekend at Air Studios. Click here to enter

TwinTrak Pro Troubleshooting Guide

No LEDs illuminate


• Is the POWER switched on?

• Is the correct mains voltage being used for your unit? If not, the fuse may blow, requiring the correct fuse to be refitted. (Click here to find the fuse rating for your unit.)

No output when using the MIC INPUT


• Is the power switched on?

• Is the LINE switch on the front panel switched out?

• Is the INST switch on the front panel switched out?

• Is the LEVEL set correctly?

• For microphones that require phantom power, is the +48V switch engaged? (If you are unsure whether your microphone requires phantom power, check the user guide for your microphone.)

• Is there something connected to the insert send/return?

No output when using the LINE INPUT


• Is the power switched on?

• Is the LINE switch on the front panel switched in?

• Is the INST switch on the front panel switched out?

• Is the LEVEL set correctly?

• Is there something connected to the insert send/return?

No output when using the INSTRUMENT INPUT


• Is the power switched on?

• Is the INST switch on the front panel switched in?

• Is the LEVEL set correctly?

• Is there something connected to the insert send/return?

The OPTICAL COMPRESSOR is not working


• Is the compressor section’s IN switch engaged?

• Is the LEVEL set correctly? If set too low, the signal level may not be high enough to activate the compressor.

• Are the COMPRESSION controls set correctly? If threshold is too high, the input may not reach the level at which compression starts. (See user manual)

• Is something connected to the compressor sidechain input?

The OPTICAL COMPRESSOR is only working on the top channel


• Is the lower channel compressor sections’ IN switch engaged?

• Is the STEREO LINK switch engaged? If so, only the compression meter on the top channel displays the gain reduction and only the top channel controls have an effect on the compression settings. The top channel is called the master, as it controls both compressors when in stereo mode.

• Is something connected to the compressor sidechain input?

The MID SCOOP EQ is not working


• Is the EQ section’s IN switch engaged?

• Is the CUT FREQUENCY control set to a frequency that is present in the signal?

No word clock lock


• Is your external word clock source transmitting word clock?

• Is the sample frequency set to match that of the word clock-transmitting device?

• Is an external word clock cable needed and, if so, is it connected? (See clocking regulations in the GENERIC SETUP)

No output from the digital output option


• Is the sample frequency set correctly?

• Is the receiving device set to receive at 24 bit?

• Is the receiving device set to external sync? (See DIGITAL in GENERIC SETUP)

• Is the signal format set correctly, Pro or Consumer, set with jumper J2? (See Platinum A/D card Jumpers section in GENERIC SETUP)

Digital Card seems to clip before reaching 0dBFS


• Have the jumpers been removed from the A/D card? (See A/D card installation for more details)